Degraded Esper Services

Incident Report for Esper.io

Resolved

All services have been fully restored and are now fully operational.

We appreciate your patience. If you notice any issues, please contact our support team.
Posted Mar 18, 2025 - 19:42 UTC

Monitoring

All the impacted services has been fixed. We are monitoring the impacted services.
Posted Mar 18, 2025 - 18:57 UTC

Investigating

Impacted Services:

- Esper Home Page (www.esper.io)
- Esper Help Page
- New Sign-ups (Try Esper)
- Esper.io Emails
- Some artifact repositories

We are actively working on resolving this and will post updates here periodically.
Posted Mar 18, 2025 - 18:22 UTC
This incident affected: Esper Systems.