SharedOrgn3 Outage

Incident Report for Esper.io

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 22:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 04, 2025 - 22:18 UTC

Monitoring

A fix has been successfully implemented and tenants are coming back up and should be accessible now.
Posted Nov 04, 2025 - 22:17 UTC

Identified

The issue has been identified and a fix is been implemented.
Posted Nov 04, 2025 - 22:14 UTC

Investigating

We are currently investigating an issue which is affecting some customers who is not able to access their tenants.
Posted Nov 04, 2025 - 22:10 UTC
This incident affected: Esper Systems.