VPP App Management Delays Following Apple Service Disruption

Incident Report for Esper.io

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 11:45 UTC

Update

Apple has confirmed that the performance degradation is resolved, and we have observed that VPP operations are back to normal. We are continuing to monitor the situation.
Posted Mar 03, 2025 - 17:36 UTC

Update

Apple continues to report performance degradation. We are actively monitoring the situation. Further updates will be provided as we receive more information.
Posted Mar 01, 2025 - 16:41 UTC

Update

Apple has updated its status page, confirming performance degradation. We are actively monitoring the situation. Further updates will be provided as we receive more information.
Posted Feb 28, 2025 - 15:22 UTC

Monitoring

Apple's VPP service recently experienced an outage, which has now been marked as resolved on Apple's status page. However, we are still observing some lag on Apple's side and are actively monitoring the situation. This may impact VPP app management on Esper.
Posted Feb 28, 2025 - 11:07 UTC
This incident affected: Esper Systems.