Incorrect tenant deletion email

Incident Report for Esper.io

Resolved

You may have just received an email from us saying your tenant is being deleted on August 28th. This was a mistake on our end. We have sent an update to all the impacted customers.
Posted Aug 21, 2025 - 17:20 UTC

Investigating

You may have just received an email from us saying your tenant is being deleted on August 28th. This was a mistake on our end.
Posted Aug 21, 2025 - 16:33 UTC